WP Content Security Policy Plugin ver 1.8 で WordPress 4.9 が真っ白になる備忘録

Server
Photo by hyt.

WP Content Security Policy Plugin の ver1.8 へのアップデートの影響で,本 blog が18時くらいから先ほど(現在23:52分)まで停止していることに気が付いていませんでした.

現在のところ,WP Content Security Policy (CSP) Plugin を停止させ(一旦削除して)再稼働中ですが,これ,

WP Content Security Plugin
Block XSS vulnerabilities by adding a Content Security Policy header, plugin receives violations to easily maintain the ...

にある通り,セキュリティ向上のためのプラグインなので,このままは少し困りますねぇ.

なお,CSP についての日本語の解説は

コンテンツセキュリティポリシー (CSP) - HTTP | MDN
コンテンツセキュリティポリシー (CSP) は、クロスサイトスクリプティング (Cross-site_scripting) やデータインジェクション攻撃などのような、特定の種類の攻撃を検知し、影響を軽減するために追加できるセキュリティレイヤ...

にあります.

WordPress の ver は 4.9 と最新なのですが,アップデートでバグが入り込んだから STOP したのか,それとも他の plugin との相性問題なのかは不明です.


PS. Support ページ

WP Content Security Log remains empty
Support » Plugin: WP Content Security Plugin » WP Content Security Log remains empty WP Content Security Log remains emp...

で,私と同様の現象の報告が行われていますが,現在の所何も進展がない模様.しばらく様子見ですかね.

2019年11月24日追記:ver1.9 もダメみたい.syntax error があるそうでプラグインを有効化できません.

2009年12月06日追記:ver2.0 だと大丈夫みたいですね.詳しくは,

500 Error
Support » Plugin: WP Content Security Plugin » 500 Error 500 Error Resolved huislaw (@huislaw) 5 years, 5 months ago Hi,...

を参照してみてください.

Server
スポンサーリンク
Following hyt!
hyt adversaria
タイトルとURLをコピーしました