Ubuntu on kernel 6.5.0-14 で dkms に失敗する備忘録

Environment
Photo by hyt.

Ubuntu on kernel 6.5.0-14 で dkms に失敗する備忘録です.

結論から記すと,

gcc-12 を入れる

で解決する可能性があります.

おきたこと

Kernel 6-5 環境にアップデートされた elementary os 環境でなぜか BlackmagicDesign の UltraStudio Recorder 3G の dkms によるカーネルモジュールの導入時にエラーが出てしまいました.dkms のエラーログを調べたところ,gcc-12 が必要とのことで,

$ sudo apt install gcc-12

とすると無事解決しました.

同様の事例が,

[SOLVED] new kernel 6.5.0-14(22.04) can not compile NVIDIA display card driver
help!!! Today, after I update the kernel from 6.2.0-39 to 6.5.0-14, I find the latest NVIDIA display driver can not be i...

にもありますが,どうも導入した Kernel をコンパイルしたのと同じかそれより上のバージョンでモジュールもコンパイルしないといけないみたいですね.

以上!

EnvironmentServer
スポンサーリンク
Following hyt!
hyt adversaria
タイトルとURLをコピーしました