Alpine Linux 3.10.2 で gcc-8.3.0-r0 が入れられない備忘録

Photo by hyt.

Alpine Linux 3.10.2 で gcc-8.3.0-r0 が入れられない備忘録です.

Alpine Linux 3.10.2 をインストールして gcc を入れようとしたんですが,以下の様なエラーが出てなぜかインストールできません.

最初はディスク容量が足りないのかと思ったんですが,そうではなくて,gcc パッケージのバグのようです.どうも書き込みの権限が不足しているみたい.

応急処置は以下の通り.

単なるパッケージングのミスでしょうし,すでに報告もされているようなのですぐに修正されることとは思いますが,ピンポイントで引っかかる人もいるかもしれないので,一応備忘録としておきます.


どうも g++-8.3.0-r0 とか openssl-dev も同じエラーが出るみたい.上と同様に対処すれば何とかなりはしますが,風数パッケージでおきるということは,パッケージング全体に係る何かのバグが入り込んでいるのかもしれないですね.


以上!

スポンサーリンク
large rectangle advertisement
スポンサーリンク
large rectangle advertisement